IP Subnet Cheat Sheet
Every IPv4 prefix from /32 to /8 with its subnet mask, wildcard mask, total addresses and usable hosts. For example, a /24 is 255.255.255.0 (wildcard 0.0.0.255) with 256 addresses and 254 usable hosts.
Updated
IPv4 Subnetting Chart
| CIDR | Subnet Mask | Wildcard | Addresses | Usable Hosts |
|---|---|---|---|---|
| /32 | 255.255.255.255 | 0.0.0.0 | 1 | 11 |
| /31 | 255.255.255.254 | 0.0.0.1 | 2 | 22 |
| /30 | 255.255.255.252 | 0.0.0.3 | 4 | 2 |
| /29 | 255.255.255.248 | 0.0.0.7 | 8 | 6 |
| /28 | 255.255.255.240 | 0.0.0.15 | 16 | 14 |
| /27 | 255.255.255.224 | 0.0.0.31 | 32 | 30 |
| /26 | 255.255.255.192 | 0.0.0.63 | 64 | 62 |
| /25 | 255.255.255.128 | 0.0.0.127 | 128 | 126 |
| /24 | 255.255.255.0 | 0.0.0.255 | 256 | 254 |
| /23 | 255.255.254.0 | 0.0.1.255 | 512 | 510 |
| /22 | 255.255.252.0 | 0.0.3.255 | 1,024 | 1,022 |
| /21 | 255.255.248.0 | 0.0.7.255 | 2,048 | 2,046 |
| /20 | 255.255.240.0 | 0.0.15.255 | 4,096 | 4,094 |
| /19 | 255.255.224.0 | 0.0.31.255 | 8,192 | 8,190 |
| /18 | 255.255.192.0 | 0.0.63.255 | 16,384 | 16,382 |
| /17 | 255.255.128.0 | 0.0.127.255 | 32,768 | 32,766 |
| /16 | 255.255.0.0 | 0.0.255.255 | 65,536 | 65,534 |
| /15 | 255.254.0.0 | 0.1.255.255 | 131,072 | 131,070 |
| /14 | 255.252.0.0 | 0.3.255.255 | 262,144 | 262,142 |
| /13 | 255.248.0.0 | 0.7.255.255 | 524,288 | 524,286 |
| /12 | 255.240.0.0 | 0.15.255.255 | 1,048,576 | 1,048,574 |
| /11 | 255.224.0.0 | 0.31.255.255 | 2,097,152 | 2,097,150 |
| /10 | 255.192.0.0 | 0.63.255.255 | 4,194,304 | 4,194,302 |
| /9 | 255.128.0.0 | 0.127.255.255 | 8,388,608 | 8,388,606 |
| /8 | 255.0.0.0 | 0.255.255.255 | 16,777,216 | 16,777,214 |
| 1 A /32 is a single host address (host route or loopback). 2 A /31 uses both addresses on point-to-point links (RFC 3021). | ||||
IPv6 Subnet Chart
Number of subnets created per given prefix.
| Prefix | /48 | /56 | /64 | /127 | Total Addresses |
|---|---|---|---|---|---|
| /24 | 16M | 4G | 1T | 8,388,608Y | 16,777,216Y |
| /25 | 8M | 2G | 512G | 4,194,304Y | 8,388,608Y |
| /26 | 4M | 1G | 256G | 2,097,152Y | 4,194,304Y |
| /27 | 2M | 512M | 128G | 1,048,576Y | 2,097,152Y |
| /28 | 1M | 256M | 64G | 524,288Y | 1,048,576Y |
| /29 | 512K | 128M | 32G | 262,144Y | 524,288Y |
| /30 | 256K | 64M | 16G | 131,072Y | 262,144Y |
| /31 | 128K | 32M | 8G | 65,536Y | 131,072Y |
| /32 | 64K | 16M | 4G | 32,768Y | 65,536Y |
| /33 | 32K | 8M | 2G | 16,384Y | 32,768Y |
| /34 | 16K | 4M | 1G | 8,192Y | 16,384Y |
| /35 | 8K | 2M | 512M | 4,096Y | 8,192Y |
| /36 | 4K | 1M | 256M | 2,048Y | 4,096Y |
| /37 | 2K | 512K | 128M | 1,024Y | 2,048Y |
| /38 | 1K | 256K | 64M | 512Y | 1,024Y |
| /39 | 512 | 128K | 32M | 256Y | 512Y |
| /40 | 256 | 64K | 16M | 128Y | 256Y |
| /41 | 128 | 32K | 8M | 64Y | 128Y |
| /42 | 64 | 16K | 4M | 32Y | 64Y |
| /43 | 32 | 8K | 2M | 16Y | 32Y |
| /44 | 16 | 4K | 1M | 8Y | 16Y |
| /45 | 8 | 2K | 512K | 4Y | 8Y |
| /46 | 4 | 1K | 256K | 2Y | 4Y |
| /47 | 2 | 512 | 128K | 1Y | 2Y |
| /48 | 1 | 256 | 64K | 512Z | 1Y |
| /49 | - | 128 | 32K | 256Z | 512Z |
| /50 | - | 64 | 16K | 128Z | 256Z |
| /51 | - | 32 | 8K | 64Z | 128Z |
| /52 | - | 16 | 4K | 32Z | 64Z |
| /53 | - | 8 | 2K | 16Z | 32Z |
| /54 | - | 4 | 1K | 8Z | 16Z |
| /55 | - | 2 | 512 | 4Z | 8Z |
| /56 | - | 1 | 256 | 2Z | 4Z |
| /57 | - | - | 128 | 1Z | 2Z |
| /58 | - | - | 64 | 512E | 1Z |
| /59 | - | - | 32 | 256E | 512E |
| /60 | - | - | 16 | 128E | 256E |
| /61 | - | - | 8 | 64E | 128E |
| /62 | - | - | 4 | 32E | 64E |
| /63 | - | - | 2 | 16E | 32E |
| /64 | - | - | 1 | 8E | 16E |
Units: Y = 1,208,925,819,614,629,174,706,176; Z = 1,180,591,620,717,411,303,424; E = 1,152,921,504,606,846,976; T = 1,099,511,627,776; G = 1,073,741,824; M = 1,048,576; K = 1,024
Subnetting quick answers
How many usable hosts are in a subnet?
Usable hosts = 2(32 − prefix) − 2, because the network and broadcast addresses are reserved. A /26 has 64 addresses and 62 usable hosts. A /31 is the exception: both of its addresses are usable on point-to-point links.
What is a wildcard mask?
A wildcard mask is the inverse of the subnet mask: subtract each octet from 255. The wildcard for 255.255.255.224 (/27) is 0.0.0.31. Cisco ACLs and OSPF use wildcard masks.
How do I convert a subnet mask to CIDR?
Count the 1 bits in the mask. 255.255.255.192 is 24 + 2 = 26 ones, so it is a /26. See RFC 4632 for CIDR notation.
Which IPv6 prefix should a network use?
Use a /64 for each LAN, as SLAAC requires (RFC 4291). Sites typically receive a /48 or /56, which give 65,536 or 256 /64 subnets.
Need a specific network? Use the subnet calculator or read how to subnet.